Fedora-Fr - Communauté francophone Fedora - Linux

Planet de Fedora-Fr : la communauté francophone autour de la distribution Linux Fedora

A propos

Cette page est actualisée toutes les heures.

Cette page est une sélection de blogs autour de Fedora. Fedora-Fr.org décline toute responsabilité au sujet des propos tenus par les auteurs des blogs de ce planet. Leurs propos sont leur entière responsabilité.

Le contenu de ce planet appartient à leurs auteurs respectifs. Merci de consulter leur blogs pour obtenir les licences respectives.

Mot-clefs : Archives

PHP version 5.6.26RC1 et 7.0.11RC1

Remi Collet

Les versions Release Candidate sont disponibles dans le dépôt remi-test pour Fedora et Enterprise Linux (RHEL / CentOS) afin de permettre au plus grand nombre de les tester. Elles sont  fournit en Software Collections, pour une installation en parallèle, solution idéale pour ce type de tests. Uniquement pour x86_64.

Les RPM de PHP version 5.6.26RC1 sont disponibles en SCL et en paquets de base dans le dépôt remi-test pour Fedora21 et Enterprise Linux6.

Les RPM de PHP version 7.0.11C1 sont disponibles en SCL dans le dépôt remi-test et les paquets de base dans le dépôt remi-php70-test pour Fedora 21 et Enterprise Linux6.

emblem-notice-24.pngInstallation : voir la Configuration du dépôt et choisir la version.

Installation en parallèle, en Software Collections de PHP 5.6 :

yum --enablerepo=remi-test install php56

Installation en parallèle, en Software Collections de PHP 7.0 :

yum --enablerepo=remi-test install php70

Mise à jour, de PHP 5.6 :

yum --enablerepo=remi-php56,remi-test update php\*

Mise à jour, de PHP 7.0 :

yum --enablerepo=remi-php70,remi-php70-test update php\*

A noter : la version 7.0.11RC1 est aussi disponible dans Fedora rawhide.

emblem-notice-24.pngLa version RC est généralement identique à la version finale (aucun changement accepté, à l'exception de correctifs de sécurité).

Software Collections (php56, php70)

Paquets standards (php)

PHP version 5.6.25 et 7.0.10

Remi Collet

Avec un peu de retard en raison de mes vacances.

Les RPM de PHP version 7.0.10 sont disponibles dans le dépôt remi-php70 pour Fedora et Enterprise Linux (RHEL, CentOS).

Les RPM de PHP version 5.6.25 sont disponibles dans le dépôt remi pour Fedora ≥ 21 et remi-php56 pour Enterprise Linux.

emblem-important-2-24.pngPHP version 5.5 a atteint sa fin de vie et n'est plus maintenu par le projet.

emblem-important-2-24.pngPHP version 5.4 a atteint sa fin de vie et n'est plus maintenu par le projet.

Ces versions sont aussi disponibles en Software Collections.

security-medium-2-24.pngCes versions corrigent quelques failles de sécurité, la mise à jour est donc vivement recommandée.

Annonces des versions :

emblem-notice-24.pngInstallation : voir l'assistant de configuration et choisir la version et le mode d'installation.

Remplacement du PHP par défaut du système par la version 7.0 (le plus simple) :

yum-config-manager --enable remi-php70
yum update

Installation en parallèle, en Software Collections de PHP 7.0 (x86_64 uniquement) :

yum install php70

Remplacement du PHP par défaut du système par la version 5.6 (le plus simple) :

yum-config-manager --enable remi-php56
yum update

Installation en parallèle, en Software Collections de PHP 5.6 (x86_64 uniquement) :

yum install php56

Et bientôt dans les mises à jour officielles:

emblem-important-2-24.pngÀ noter :

  • la version EL7 est construite avec RHEL-7.2
  • la version EL6 est construite avec RHEL-6.8
  • beaucoup de nouvelles extensions sont aussi disponible, voir PECL extension RPM status page

emblem-notice-24.pngInformations, lire :

Paquets de base (php)

Software Collections (php56 / php70)

PHP version 5.6.25RC1 et 7.0.10RC1

Remi Collet

Les versions Release Candidate sont disponibles dans le dépôt remi-test pour Fedora et Enterprise Linux (RHEL / CentOS) afin de permettre au plus grand nombre de les tester. Elles sont  fournit en Software Collections, pour une installation en parallèle, solution idéale pour ce type de tests. Uniquement pour x86_64.

Les RPM de PHP version 5.6.25RC1 sont disponibles en SCL et en paquets de base dans le dépôt remi-test pour Fedora21 et Enterprise Linux6.

Les RPM de PHP version 7.0.10C1 sont disponibles en SCL dans le dépôt remi-test et les paquets de base dans le dépôt remi-php70-test pour Fedora 21 et Enterprise Linux6.

emblem-notice-24.pngInstallation : voir la Configuration du dépôt et choisir la version.

Installation en parallèle, en Software Collections de PHP 5.6 :

yum --enablerepo=remi-test install php56

Installation en parallèle, en Software Collections de PHP 7.0 :

yum --enablerepo=remi-test install php70

Mise à jour, de PHP 5.6 :

yum --enablerepo=remi-php56,remi-test update php\*

Mise à jour, de PHP 7.0 :

yum --enablerepo=remi-php70,remi-php70-test update php\*

A noter : la version 7.0.10RC1 est aussi disponible dans Fedora rawhide.

emblem-notice-24.pngLa version RC est généralement identique à la version finale (aucun changement accepté, à l'exception de correctifs de sécurité).

Software Collections (php56, php70)

Paquets standards (php)

PHP version 5.5.38, 5.6.24 et 7.0.9

Remi Collet

Les RPM de PHP version 7.0.9 sont disponibles dans le dépôt remi-php70 pour Fedora et Enterprise Linux (RHEL, CentOS).

Les RPM de PHP version 5.6.24 sont disponibles dans le dépôt remi pour Fedora ≥ 21 et remi-php56 pour Enterprise Linux.

Les RPM de PHP version 5.5.38 sont disponibles dans le dépôt remi-php55 pour Enterprise Linux.

emblem-important-2-24.pngPHP version 5.5 a atteint sa fin de vie, la version 5.5.38 est donc la dernière mise à jour. Il est donc important de d'envisager la mise à jour en version 5.6 ou 7.0.

emblem-important-2-24.pngPHP version 5.4 a atteint sa fin de vie et n'est plus maintenu par le projet. Compte tenu du nombre important de téléchargements par les utilisateurs de mon dépôt la version présente dans le dépôt remi pour Enterprise Linux (RHEL, CentOS...) a été conservée avec les correctifs de sécurité (de la version 5.5.38). La mise à jour vers une version maintenue est fortement conseillée.

Ces versions sont aussi disponibles en Software Collections.

security-medium-2-24.pngCes versions corrigent quelques failles de sécurité, la mise à jour est donc vivement recommandée.

Annonces des versions :

emblem-important-2-24.png La version 5.5.27 était la dernière mise à jour corrigeant des bugs. La branche 5.5 est donc en maintenance de sécurité uniquement (jusqu'en Juillet 2016).

emblem-notice-24.pngInstallation : voir l'assistant de configuration et choisir la version et le mode d'installation.

Remplacement du PHP par défaut du système par la version 7.0 (le plus simple) :

yum-config-manager --enable remi-php70
yum update

Installation en parallèle, en Software Collections de PHP 7.0 (x86_64 uniquement) :

yum install php70

Remplacement du PHP par défaut du système par la version 5.6 (le plus simple) :

yum-config-manager --enable remi-php56
yum update

Installation en parallèle, en Software Collections de PHP 5.6 (x86_64 uniquement) :

yum install php56

Remplacement du PHP par défaut du système par la version 5.5 (le plus simple) :

yum-config-manager --enable remi-php55
yum update

Installation en parallèle, en Software Collections de PHP 5.5 (x86_64 uniquement) :

yum --enablerepo=remi install php55

Et bientôt dans les mises à jour officielles (Fedora 25 fournira PHP 7.0):

emblem-important-2-24.pngÀ noter :

  • la version EL7 est construite avec RHEL-7.2
  • la version EL6 est construite avec RHEL-6.8
  • beaucoup de nouvelles extensions sont aussi disponible, voir PECL extension RPM status page

emblem-notice-24.pngInformations, lire :

Paquets de base (php)

Software Collections (php55 / php56 / php70)

PHP version 5.6.24RC1 et 7.0.9RC1

Remi Collet

Les versions Release Candidate sont disponibles dans le dépôt remi-test pour Fedora et Enterprise Linux (RHEL / CentOS) afin de permettre au plus grand nombre de les tester. Elles sont  fournit en Software Collections, pour une installation en parallèle, solution idéale pour ce type de tests. Uniquement pour x86_64.

Les RPM de PHP version 5.6.24RC1 en SCL sont disponibles dans le dépôt remi-test pour Fedora20 et Enterprise Linux6.

Les RPM de PHP version 7.0.9RC1 sont disponibles en SCL dans le dépôt remi-test et les paquets de base dans le dépôt remi-php70-test pour Fedora 21 et Enterprise Linux6.

La branche PHP 5.5 étant en mode "maintenance de sécurité"; il n'y a plus de RC.

emblem-notice-24.pngInstallation : voir la Configuration du dépôt et choisir la version.

Installation en parallèle, en Software Collections de PHP 5.6 :

yum --enablerepo=remi-test install php56

Installation en parallèle, en Software Collections de PHP 7.0 :

yum --enablerepo=remi-test install php70

Mise à jour, de PHP 7.0 :

yum --enablerepo=remi-php70,remi-php70-test update php\*

A noter : la version 7.0.9RC1 est aussi disponible dans Fedora rawhide.

emblem-notice-24.pngLa version RC est généralement identique à la version finale (aucun changement accepté, à l'exception de correctifs de sécurité).

Software Collections (php56, php70)

Paquets standards (php)

PHP version 5.5.37, 5.6.23 et 7.0.8

Remi Collet

Les RPM de PHP version 7.0.8 sont disponibles dans le dépôt remi-php70 pour Fedora et Enterprise Linux (RHEL, CentOS).

Les RPM de PHP version 5.6.23 sont disponibles dans le dépôt remi pour Fedora ≥ 21 et remi-php56 pour Fedora 20 et Enterprise Linux.

Les RPM de PHP version 5.5.37 sont disponibles dans le dépôt remi pour Fedora 20 et dans le dépôt remi-php55 pour Enterprise Linux.

emblem-important-2-24.pngPHP version 5.4 a atteint sa fin de vie et n'est plus maintenu par le projet. Compte tenu du nombre important de téléchargements par les utilisateurs de mon dépôt la version présente dans le dépôt remi pour Enterprise Linux (RHEL, CentOS...) a été conservée avec les correctifs de sécurité (de la version 5.5.37). La mise à jour vers une version maintenue est fortement conseillée.

Ces versions sont aussi disponibles en Software Collections.

security-medium-2-24.pngCes versions corrigent quelques failles de sécurité, la mise à jour est donc vivement recommandée.

Annonces des versions :

emblem-important-2-24.png La version 5.5.27 était la dernière mise à jour corrigeant des bugs. La branche 5.5 est donc en maintenance de sécurité uniquement (jusqu'en Juillet 2016).

emblem-notice-24.pngInstallation : voir l'assistant de configuration et choisir la version et le mode d'installation.

Remplacement du PHP par défaut du système par la version 7.0 (le plus simple) :

yum-config-manager --enable remi-php70
yum update

Installation en parallèle, en Software Collections de PHP 7.0 (x86_64 uniquement) :

yum install php70

Remplacement du PHP par défaut du système par la version 5.6 (le plus simple) :

yum-config-manager --enable remi-php56
yum update

Installation en parallèle, en Software Collections de PHP 5.6 (x86_64 uniquement) :

yum install php56

Remplacement du PHP par défaut du système par la version 5.5 (le plus simple) :

yum-config-manager --enable remi-php55
yum update

Installation en parallèle, en Software Collections de PHP 5.5 (x86_64 uniquement) :

yum --enablerepo=remi install php55

Et bientôt dans les mises à jour officielles:

emblem-important-2-24.pngÀ noter :

  • la version EL7 est construite avec RHEL-7.2
  • la version EL6 est construite avec RHEL-6.8
  • beaucoup de nouvelles extensions sont aussi disponible, voir PECL extension RPM status page

emblem-notice-24.pngInformations, lire :

Paquets de base (php)

Software Collections (php55 / php56 / php70)

PHP version 5.6.23RC1 et 7.0.8RC1

Remi Collet

Les versions Release Candidate sont disponibles dans le dépôt remi-test pour Fedora et Enterprise Linux (RHEL / CentOS) afin de permettre au plus grand nombre de les tester. Elles sont  fournit en Software Collections, pour une installation en parallèle, solution idéale pour ce type de tests. Uniquement pour x86_64.

Les RPM de PHP version 5.6.23RC1 en SCL sont disponibles dans le dépôt remi-test pour Fedora20 et Enterprise Linux6.

Les RPM de PHP version 7.0.8RC1 sont disponibles en SCL dans le dépôt remi-test et les paquets de base dans le dépôt remi-php70-test pour Fedora 21 et Enterprise Linux6.

La branche PHP 5.5 étant en mode "maintenance de sécurité"; il n'y a plus de RC.

emblem-notice-24.pngInstallation : voir la Configuration du dépôt et choisir la version.

Installation en parallèle, en Software Collections de PHP 5.6 :

yum --enablerepo=remi-test install php56

Installation en parallèle, en Software Collections de PHP 7.0 :

yum --enablerepo=remi-test install php70

Mise à jour, de PHP 7.0 :

yum --enablerepo=remi-php70,remi-php70-test update php\*

A noter : la version 5.6.22RC1 est aussi disponible dans Fedora rawhide.

emblem-notice-24.pngLa version RC est généralement identique à la version finale (aucun changement accepté, à l'exception de correctifs de sécurité).

Software Collections (php56, php70)

Paquets standards (php)

PHPUnit 5.4

Remi Collet

Les RPM de PHPUnit version 5.4 sont disponibles dans le dépôt remi pour Fedora ≥ 21 et dans le dépôt remi-test pour Enterprise Linux (CentOS, RHEL...)

Documentation : PHPUnit 5.4 manual et Release Announcement for PHPUnit 5.4.0 (english)

emblem-notice-24.pngCette nouvelle version nécessite PHP ≥ 5.6.

Cette nouvelle version nécessite aussi les mises à jour de:

  • php-phpunit-PHP-CodeCoverage-4.0.0
  • php-phpunit-PHPUnit-MockObject-3.2.0
  • php-phpunit-phpcov-3.1.0

Installation, Fedora :

dnf --enablerepo=remi install phpunit

Installation, Enterprise Linux :

yum --enablerepo=remi,remi-test,remi-php56 install phpunit

Remarque: cet outil est une pièce essentielle de la QA PHP dans Fedora. Je prévois de mettre à jour rapidement dans les dépôts officiels de Fedora.

PHP version 5.5.25RC1 et 5.6.9RC1

Remi Collet

emblem-notice-24.pngNouveauté : les versions Release Candidate sont désormais disponibles dans le dépôt remi-test pour Fedora et Enterprise Linux (RHEL / CentOS) afin de permettre au plus grand nombre de les tester. Elles sont uniquement fournit en Software Collections, pour une installation en parallèle, solution idéale pour ce type de tests.

Les RPM de PHP version 5.6.9RC1 en SCL sont disponibles dans le dépôt remi-test pour Fedora 19-22 et Enterprise Linux 6-7.

Les RPM de PHP version 5.5.25RC1 en SCL sont disponibles dans le dépôt remi-test pour Fedora 21-22 et Enterprise Linux 6-7.

emblem-notice-24.pngInstallation : voir la Configuration du dépôt et choisir la version.

Installation en parallèle, en Software Collections de PHP 5.6 (x86_64 uniquement) :

yum --enablerepo=remi,remi-test install php56

Installation en parallèle, en Software Collections de PHP 5.5 (x86_64 uniquement) :

yum --enablerepo=remi,remi-test install php55

A noter :

emblem-notice-24.pngLa version RC est généralement identique à la version finale (à l'exception de correctifs de sécurité).

Software Collections (php55/php56)

PHP version 5.4.40, 5.5.24 et 5.6.8

Remi Collet

Les RPM de PHP version 5.6.8 sont disponibles dans le dépôt remi pour Fedora 21 et remi-php56 pour Fedora ≤ 20  et Enterprise Linux (RHEL, CentOS).

Les RPM de PHP version 5.5.24 sont disponibles dans le dépôt remi pour Fedora ≤ 20 et dans le dépôt remi-php55 pour Enterprise Linux.

Les RPM de PHP version 5.4.40 sont disponibles dans le dépôt remi pour Enterprise Linux (RHEL, CentOS...).

Ces versions sont aussi disponibles en Software Collections.

security-medium-2-24.pngCes versions corrigent plusieurs failles de sécurité, la mise à jour est donc vivement recommandée.

Annonces des versions :

emblem-important-2-24.pngLa version 5.4.33 était la dernière mise à jour corrigeant des bugs. La branche 5.4 est donc en maintenance de sécurité uniquement.

emblem-notice-24.pngInstallation : voir la Configuration du dépôt et choisir la version et le mode d'installation.

Remplacement du PHP par défaut du système par la version 5.6 (le plus simple) :

yum --enablerepo=remi-php56,remi update php\*

Installation en parallèle, en Software Collections de PHP 5.6 (x86_64 uniquement) :

yum --enablerepo=remi install php56

Remplacement du PHP par défaut du système par la version 5.5 (le plus simple) :

yum --enablerepo=remi-php55,remi update php\*

Installation en parallèle, en Software Collections de PHP 5.5 (x86_64 uniquement) :

yum --enablerepo=remi install php55

Remplacement du PHP par défaut du système par la version 5.4 (entreprise uniquement) :

yum --enablerepo=remi update php\*

Installation en parallèle, en Software Collections de PHP 5.4 (x86_64 uniquement) :

yum --enablerepo=remi install php54

Et bientôt dans les mises à jour officielles:

emblem-important-2-24.pngÀ noter :

  • la version EL7 est construite avec RHEL-7.1
  • la version EL6 est construite avec RHEL-6.6
  • beaucoup de nouvelles extensions sont aussi disponible, voir PECL extension RPM status page

emblem-notice-24.pngInformations, lire :

Paquets de base (php)

Software Collections (php54/php55)

PHP version 5.5.24RC1 et 5.6.8RC1

Remi Collet

emblem-notice-24.pngNouveauté : les versions Release Candidate sont désormais disponibles dans le dépôt remi-test pour Fedora et Enterprise Linux (RHEL / CentOS) afin de permettre au plus grand nombre de les tester. Elles sont uniquement fournit en Software Collections, pour une installation en parallèle, solution idéale pour ce type de tests.

Les RPM de PHP version 5.6.8RC1 en SCL sont disponibles dans le dépôt remi-test pour Fedora 19-22 et Enterprise Linux 6-7.

Les RPM de PHP version 5.5.24RC1 en SCL sont disponibles dans le dépôt remi-test pour Fedora 21-22 et Enterprise Linux 6-7.

emblem-notice-24.pngInstallation : voir la Configuration du dépôt et choisir la version.

Installation en parallèle, en Software Collections de PHP 5.6 (x86_64 uniquement) :

yum --enablerepo=remi,remi-test install php56

Installation en parallèle, en Software Collections de PHP 5.5 (x86_64 uniquement) :

yum --enablerepo=remi,remi-test install php55

A noter :

emblem-notice-24.pngLa version RC est généralement identique à la version finale (à l'exception de correctifs de sécurité).

Software Collections (php55/php56)

PHP version 5.4.39, 5.5.23 et 5.6.7

Remi Collet

Les RPM de PHP version 5.6.7 sont disponibles dans le dépôt remi pour Fedora 21 et remi-php56 pour Fedora ≤ 20  et Enterprise Linux (RHEL, CentOS).

Les RPM de PHP version 5.5.23 sont disponibles dans le dépôt remi pour Fedora ≤ 20 et dans le dépôt remi-php55 pour Enterprise Linux.

Les RPM de PHP version 5.4.39 sont disponibles dans le dépôt remi pour Enterprise Linux (RHEL, CentOS...).

Ces versions sont aussi disponibles en Software Collections.

security-medium-2-24.pngCes versions corrigent quelques failles de sécurité, la mise à jour est vivement recommandée.

Annonces des versions :

emblem-important-2-24.pngLa version 5.4.33 était la dernière mise à jour corrigeant des bugs. La branche 5.4 est donc en maintenance de sécurité uniquement.

emblem-notice-24.pngInstallation : voir la Configuration du dépôt et choisir la version et le mode d'installation.

Remplacement du PHP par défaut du système par la version 5.6 (le plus simple) :

yum --enablerepo=remi-php56,remi update php\*

Installation en parallèle, en Software Collections de PHP 5.6 (x86_64 uniquement) :

yum --enablerepo=remi install php56

Remplacement du PHP par défaut du système par la version 5.5 (le plus simple) :

yum --enablerepo=remi-php55,remi update php\*

Installation en parallèle, en Software Collections de PHP 5.5 (x86_64 uniquement) :

yum --enablerepo=remi install php55

Remplacement du PHP par défaut du système par la version 5.4 (entreprise uniquement) :

yum --enablerepo=remi update php\*

Installation en parallèle, en Software Collections de PHP 5.4 (x86_64 uniquement) :

yum --enablerepo=remi install php54

Et bientôt dans les mises à jour officielles:

emblem-important-2-24.pngÀ noter :

  • la version EL7 est construite avec RHEL-7.0
  • la version EL6 est construite avec RHEL-6.6
  • beaucoup de nouvelles extensions sont aussi disponible, voir PECL extension RPM status page

emblem-notice-24.pngInformations, lire :

Paquets de base (php)

Software Collections (php54/php55)

PHP version 5.5.23RC1 et 5.6.7RC1

Remi Collet

emblem-notice-24.pngNouveauté : les versions Release Candidate sont désormais disponibles dans le dépôt remi-test pour Fedora et Enterprise Linux (RHEL / CentOS) afin de permettre au plus grand nombre de les tester. Elles sont uniquement fournit en Software Collections, pour une installation en parallèle, solution idéale pour ce type de tests.

Les RPM de PHP version 5.6.7RC1 en SCL sont disponibles dans le dépôt remi-test pour Fedora 19-22 et Enterprise Linux.

Les RPM de PHP version 5.5.23RC1 en SCL sont disponibles dans le dépôt remi-test pour Fedora 21-22 et Enterprise Linux.

emblem-notice-24.pngInstallation : voir la Configuration du dépôt et choisir la version.

Installation en parallèle, en Software Collections de PHP 5.6 (x86_64 uniquement) :

yum --enablerepo=remi,remi-test install php56

Installation en parallèle, en Software Collections de PHP 5.5 (x86_64 uniquement) :

yum --enablerepo=remi,remi-test install php55

A noter, la version 5.6.5RC1 est aussi disponible dans Fedora rawhide.

emblem-notice-24.pngLa version RC est généralement identique à la version finale (à l'exception de correctifs de sécurité).

Software Collections (php55/php56)

PHP version 5.4.38, 5.5.22 et 5.6.6

Remi Collet

Les RPM de PHP version 5.6.6 sont disponibles dans le dépôt remi pour Fedora 21 et remi-php56 pour Fedora ≤ 20  et Enterprise Linux (RHEL, CentOS).

Les RPM de PHP version 5.5.22 sont disponibles dans le dépôt remi pour Fedora ≤ 20 et dans le dépôt remi-php55 pour Enterprise Linux.

Les RPM de PHP version 5.4.38 sont disponibles dans le dépôt remi pour Enterprise Linux (RHEL, CentOS...).

Ces versions sont aussi disponibles en Software Collections.

security-medium-2-24.pngCes versions corrigent quelques failles de sécurité, la mise à jour est vivement recommandée.

Annonces des versions :

emblem-important-2-24.pngLa version 5.4.33 était la dernière mise à jour corrigeant des bugs. La branche 5.4 est donc en maintenance de sécurité uniquement.

emblem-notice-24.pngInstallation : voir la Configuration du dépôt et choisir la version et le mode d'installation.

Remplacement du PHP par défaut du système par la version 5.6 (le plus simple) :

yum --enablerepo=remi-php56,remi update php\*

Installation en parallèle, en Software Collections de PHP 5.6 (x86_64 uniquement) :

yum --enablerepo=remi install php56

Remplacement du PHP par défaut du système par la version 5.5 (le plus simple) :

yum --enablerepo=remi-php55,remi update php\*

Installation en parallèle, en Software Collections de PHP 5.5 (x86_64 uniquement) :

yum --enablerepo=remi install php55

Remplacement du PHP par défaut du système par la version 5.4 (entreprise uniquement) :

yum --enablerepo=remi update php\*

Installation en parallèle, en Software Collections de PHP 5.4 (x86_64 uniquement) :

yum --enablerepo=remi install php54

Et bientôt dans les mises à jour officielles:

emblem-important-2-24.pngÀ noter :

  • la version EL7 est construite avec RHEL-7.0
  • la version EL6 est construite avec RHEL-6.6
  • beaucoup de nouvelles extensions sont aussi disponible, voir PECL extension RPM status page

emblem-notice-24.pngInformations, lire :

Paquets de base (php)

Software Collections (php54/php55)

PHPUnit 4.5

Remi Collet

Les RPM de PHPUnit version 4.5 sont disponibles dans le dépôt remi pour Fedora et Enterprise Linux (CentOS, RHEL...)

Documentation : PHPUnit 4.5 manual  et Release Announcement for PHPUnit 4.5.0 (english)

Installation :

yum --enablerepo=remi install phpunit

Merci de tester cette nouvelle version, qui devrait bientôt être disponible dans Fedora 21, Rawhide et EPEL-7 (bloqué par les revues #1192493 et #1188530).

Remarque: cet outil est un epièce essentielle de la QA PHP dans Fedora.

PHP version 5.4.37, 5.5.21 et 5.6.5

Remi Collet

Les RPM de PHP version 5.6.5 sont disponibles dans le dépôt remi pour Fedora 21 et remi-php56 pour Fedora ≤ 20  et Enterprise Linux (RHEL, CentOS).

Les RPM de PHP version 5.5.21 sont disponibles dans le dépôt remi pour Fedora ≤ 20 et dans le dépôt remi-php55 pour Enterprise Linux.

Les RPM de PHP version 5.4.37 sont disponibles dans le dépôt remi pour Enterprise Linux (RHEL, CentOS...).

Ces versions sont aussi disponibles en Software Collections.

security-medium-2-24.pngCes versions corrigent quelques failles de sécurité, la mise à jour est vivement recommandée.

Annonces des versions :

emblem-important-2-24.pngLa version 5.4.33 était la dernière mise à jour corrigeant des bugs. La branche 5.4 est donc en maintenance de sécurité uniquement.

emblem-notice-24.pngInstallation : voir la Configuration du dépôt et choisir la version et le mode d'installation.

Remplacement du PHP par défaut du système par la version 5.6 (le plus simple) :

yum --enablerepo=remi-php56,remi update php\*

Installation en parallèle, en Software Collections de PHP 5.6 (x86_64 uniquement) :

yum --enablerepo=remi install php56

Remplacement du PHP par défaut du système par la version 5.5 (le plus simple) :

yum --enablerepo=remi-php55,remi update php\*

Installation en parallèle, en Software Collections de PHP 5.5 (x86_64 uniquement) :

yum --enablerepo=remi install php55

Remplacement du PHP par défaut du système par la version 5.4 (entreprise uniquement) :

yum --enablerepo=remi update php\*

Installation en parallèle, en Software Collections de PHP 5.4 (x86_64 uniquement) :

yum --enablerepo=remi install php54

Et bientôt dans les mises à jour officielles:

emblem-important-2-24.pngÀ noter :

  • la version EL7 est construite avec RHEL-7.0
  • la version EL6 est construite avec RHEL-6.6
  • beaucoup de nouvelles extensions sont aussi disponible, voir PECL extension RPM status page

emblem-notice-24.pngInformations, lire :

Paquets de base (php)

Software Collections (php54/php55)

PHP version 5.5.21RC1 et 5.6.5RC1

Remi Collet

emblem-notice-24.pngNouveauté : les versions Release Candidate sont désormais disponibles dans le dépôt remi-test pour Fedora et Enterprise Linux (RHEL / CentOS) afin de permettre au plus grand nombre de les tester. Elles sont uniquement fournit en Software Collections, pour une installation en parallèle, solution idéale pour ce type de tests.

Les RPM de PHP version 5.6.5RC1 en SCL sont disponibles dans le dépôt remi-test pour Fedora 19-21 et Enterprise Linux.

Les RPM de PHP version 5.5.21RC1 en SCL sont disponibles dans le dépôt remi-test pour Fedora 21 et Enterprise Linux.

emblem-notice-24.pngInstallation : voir la Configuration du dépôt et choisir la version.

Installation en parallèle, en Software Collections de PHP 5.6 (x86_64 uniquement) :

yum --enablerepo=remi,remi-test install php56

Installation en parallèle, en Software Collections de PHP 5.5 (x86_64 uniquement) :

yum --enablerepo=remi,remi-test install php55

A noter, la version 5.6.5RC1 est aussi disponible dans Fedora rawhide.

emblem-notice-24.pngLa version RC est généralement identique à la version finale (à l'exception de correctifs de sécurité).

Software Collections (php55/php56)

PHP version 5.4.36, 5.5.20 et 5.6.4

Remi Collet

Les RPM de PHP version 5.6.4 sont disponibles dans le dépôt remi pour Fedora 21 et remi-php56 pour Fedora ≤ 20  et Enterprise Linux (RHEL, CentOS).

Les RPM de PHP version 5.5.20 sont disponibles dans le dépôt remi pour Fedora ≤ 20 et dans le dépôt remi-php55 pour Enterprise Linux.

Les RPM de PHP version 5.4.36 sont disponibles dans le dépôt remi pour Enterprise Linux (RHEL, CentOS...).

Ces versions sont aussi disponibles en Software Collections.

security-medium-2-24.pngCes versions corrigent quelques failles de sécurité, la mise à jour est vivement recommandée.

Annonces des versions :

emblem-important-2-24.pngLa version 5.4.33 était la dernière mise à jour corrigeant des bugs. La branche 5.4 est donc en maintenance de sécurité uniquement.

emblem-notice-24.pngInstallation : voir la Configuration du dépôt et choisir la version et le mode d'installation.

Remplacement du PHP par défaut du système par la version 5.6 (le plus simple) :

yum --enablerepo=remi-php56,remi update php\*

Installation en parallèle, en Software Collections de PHP 5.6 (x86_64 uniquement) :

yum --enablerepo=remi install php56

Remplacement du PHP par défaut du système par la version 5.5 (le plus simple) :

yum --enablerepo=remi-php55,remi update php\*

Installation en parallèle, en Software Collections de PHP 5.5 (x86_64 uniquement) :

yum --enablerepo=remi install php55

Remplacement du PHP par défaut du système par la version 5.4 (entreprise uniquement) :

yum --enablerepo=remi update php\*

Installation en parallèle, en Software Collections de PHP 5.4 (x86_64 uniquement) :

yum --enablerepo=remi install php54

Et bientôt dans les mises à jour officielles:

emblem-important-2-24.pngÀ noter :

  • la version EL7 est construite avec RHEL-7.0
  • la version EL6 est construite avec RHEL-6.6
  • pour php 5.5, l'extension Zip est désormais fournit dans le paquet php-pecl-zip.
  • beaucoup de nouvelles extensions sont aussi disponible, voir PECL extension RPM status page

emblem-notice-24.pngInformations, lire :

Paquets de base (php)

Software Collections (php54/php55)

phpMyAdmin version 4.3

Remi Collet

Les RPM pour installer la nouvelle version majeure de phpMyAdmin sont disponibles dans le dépôt remi pour Fedora et Enterprise Linux (RHEL, CentOS...).

Site officiel : http://www.phpmyadmin.net/

Je ne sais pas encore si cette nouvelle version majeure sera rapidement disponible dans les mises à jour officielles de Fedora ou de EPEL (actuellement en 4.2.x), mais la version 4.0.x devrait rester dans EPEL-6 (pré-requis sur MySQL 5.5). Donc il est déjà disponible pour fedora 17 à 21 et enterprise linux 5 à 7 dans le dépôt remi.

Comme toujours :

yum --enablerepo=remi install phpMyAdmin

Je vous laisse découvrir cette nouvelle version qui intègre beaucoup de nouveautés (ajax, graphique, préférences, ...), et remonter vos impressions.

Firefox 4.0 Beta 12

Remi Collet

Les RPM de la douzième beta de la prochaine version majeure du navigateur de la Fondation Mozilla est disponible dans le dépôt remi pour Fedora >= 10. Disponible en 78 langues.

Le paquet firefox4-4.0-0.26.beta12 installe cette nouvelle version à côté de la version 3.x. Vous aurez donc 2 options dans le menu Internet. Commencez par lire : Mozilla Firefox 4 Beta Release Notes (Notes de version en anglais) A propos de Firefox 4 Beta (Tristan Nitot). Comme toujours : yum remove firefox4yum --enablerepo=remi install... Lire Firefox 4.0 Beta 12