Fedora-Fr - Communauté francophone Fedora - Linux

Planet de Fedora-Fr : la communauté francophone autour de la distribution Linux Fedora

A propos

Cette page est actualisée toutes les heures.

Cette page est une sélection de blogs autour de Fedora. Fedora-Fr.org décline toute responsabilité au sujet des propos tenus par les auteurs des blogs de ce planet. Leurs propos sont leur entière responsabilité.

Le contenu de ce planet appartient à leurs auteurs respectifs. Merci de consulter leur blogs pour obtenir les licences respectives.

Mot-clefs : R

PHP version 7.3.23RC1 et 7.4.11RC1

Remi Collet

Les versions Release Candidate sont disponibles dans le dépôt de test pour Fedora et Enterprise Linux (RHEL / CentOS) afin de permettre au plus grand nombre de les tester. Elles sont  fournit en Software Collections, pour une installation en parallèle, solution idéale pour ce type de tests.et également en paquets de base.

Les RPM de PHP version 7.4.11RC1 sont disponibles en SCL dans le dépôt remi-test et les paquets de base dans le dépôt remi-test pour Fedora 32-33 ou remi-php74-test pour Fedora 31 et Enterprise Linux 7-8

Les RPM de PHP version 7.3.23RC1 sont disponibles en SCL dans le dépôt remi-test et les paquets de base dans le dépôt remi-test pour Fedora 31 ou remi-php73-test pour Enterprise Linux.

emblem-notice-24.pngPHP version 7.2 est désormais en mode maintenance de sécurité, il n'y aura donc plus de Release Candidate.

emblem-notice-24.pngInstallation : voir la Configuration du dépôt et choisir la version.

Installation en parallèle, en Software Collections de PHP 7.4 :

yum --enablerepo=remi-test install php74

Installation en parallèle, en Software Collections de PHP 7.3 :

yum --enablerepo=remi-test install php73

Mise à jour, de PHP 7.4 :

yum --enablerepo=remi-php73,remi-php74-test update php\*

ou, en utilisant le module (Fedora et RHEL 8) :

dnf module reset php
dnf module enable php:remi-7.4
dnf --enablerepo=remi-modular-test update php\*

Mise à jour, de PHP 7.3:

yum --enablerepo=remi-php73,remi-php73-test update php\*

ou, en utilisant le module (Fedora et RHEL 8) :

dnf module reset php
dnf module enable php:remi-7.3
dnf --enablerepo=remi-modular-test update php\*

A noter : la version 7.4.11RC1 est aussi dans Fedora rawhide pour la QA

emblem-notice-24.pngles paquets x86_64 utilisent désormais le client Oracle version 19.8

emblem-notice-24.pngLes paquets pour EL-8 on été construit à partir de RHEL-8.2

emblem-notice-24.pngLes paquets pour EL-7 on été construit à partir de RHEL-7.8

emblem-notice-24.pngLa version RC est généralement identique à la version finale (aucun changement accepté, à l'exception de correctifs de sécurité)

emblem-notice-24.pngLa version 8.0.0beta4 est également disponible

 

Software Collections (php73, php74)

Paquets standards (php)

PHP en route vers la sortie de la version 8.0.0

Remi Collet

La version 8.0.0 Beta 3 a été publiée. C'est maintenant la phase de stabilisation qui commence pour les développeurs, et de test pour les utilisateurs.

Les RPM sont disponibles dans le dépôt remi-php80 pour Fedora 31 et et Enterprise Linux 7 (RHEL, CentOS) ou dans le stream php:remi--8.0 ainsi qu'en Software Collection dans le dépôt remi-safe (ou remi pour Fedora).

 

emblem-important-4-24.pngLe dépôt contient actuellement des versions en cours de développement qui ne sont pas destinées à être utilisées en production.

Lire aussi : PHP 8.0 en Software Collection

emblem-notice-24.pngInstallation : voir la Configuration du dépôt et choisir le mode d'installation.

Remplacement du PHP par défaut du système par la version 8.0 avec les modules (le plus simple pour Fedora et EL-8) :

dnf module disable php
dnf module install php:remi-8.0
dnf update

Remplacement du PHP par défaut du système par la version 8.0 avec le dépôt (le plus simple pour EL-7) :

yum-config-manager --enable remi-php80
yum update php\*

Installation en parallèle, en Software Collection de PHP 8.0 (recommandée pour les tests) :

yum install php80

emblem-important-2-24.pngÀ noter :

  • la version EL8 est construite avec RHEL-8.2
  • la version EL7 est construite avec RHEL-7.8
  • beaucoup d'extensions sont aussi disponibles, voir la page PECL extension RPM status.
  • suivre les commentaires pour les mise à jour jusqu'à la version finale.

emblem-notice-24.pngInformations, lire :

Paquets de base (php)

Software Collections (php74)

PHP version 7.3.22 et 7.4.10

Remi Collet

Les RPM de PHP version 7.4.10 sont disponibles dans le dépôt remi pour Fedora 32-33 et dans le dépôt remi-php74 pour Fedora 31 et Enterprise Linux 7 (RHEL, CentOS).

Les RPM de PHP version 7.3.22 sont disponibles dans le dépôt remi pour Fedora 31 et dans le dépôt remi-php73 pour Enterprise Linux 6 (RHEL, CentOS).

emblem-notice-24.pngPas de correctifs de sécurité ce mois ci, donc pas de mise à jour de la version 7.2.33.

emblem-important-2-24.png PHP version 7.1 a atteint sa fin de vie et n'est plus maintenu par le projet PHP.

Ces versions sont aussi disponibles en Software Collections dans le dépôt remi-safe et en module pour Fedora 31-33 et EL-8.

Annonces des versions :

emblem-notice-24.pngInstallation : voir l'assistant de configuration et choisir la version et le mode d'installation.

Remplacement du PHP par défaut du système par la version 7.4 (le plus simple) :

yum-config-manager --enable remi-php74
yum update

ou, en utilisant le module (Fedora et EL-8) :

dnf module enable php:remi-7.4
dnf update php\*

Installation en parallèle, en Software Collection de PHP 7.4

yum install php74

Remplacement du PHP par défaut du système par la version 7.3 (le plus simple) :

yum-config-manager --enable remi-php73
yum update

ou, en utilisant le module (Fedora et EL-8) :

dnf module enable php:remi-7.3
dnf update php\*

Installation en parallèle, en Software Collection de PHP 7.3

yum install php73

Et bientôt dans les mises à jour officielles:

emblem-important-2-24.pngÀ noter :

  • les paquets EL-8 sont construits avec RHEL-8.2
  • les paquets EL-7 sont construits avec RHEL-7.8
  • les paquets EL-6 sont construits avec RHEL-6.10
  • les paquets EL-7 utilisent désormais libicu65 (version 65.1)
  • les paquets EL utilisent désormais oniguruma5php (version 6.9.5, au lieu de la version ancienne du système)
  • l'extension oci8 utilise désormais le client Oracle version 19.8 (sauf EL-6)
  • beaucoup de nouvelles extensions sont aussi disponible, voir PECL extension RPM status page

emblem-notice-24.pngInformations, lire :

Paquets de base (php)

Software Collections (php72 / php73 / php74)

PHP version 7.3.22RC1 et 7.4.10RC1

Remi Collet

Les versions Release Candidate sont disponibles dans le dépôt de test pour Fedora et Enterprise Linux (RHEL / CentOS) afin de permettre au plus grand nombre de les tester. Elles sont  fournit en Software Collections, pour une installation en parallèle, solution idéale pour ce type de tests.et également en paquets de base.

Les RPM de PHP version 7.4.10RC1 sont disponibles en SCL dans le dépôt remi-test et les paquets de base dans le dépôt remi-test pour Fedora 32 ou remi-php74-test pour Fedora 30-31 et Enterprise Linux 7-8

Les RPM de PHP version 7.3.22RC1 sont disponibles en SCL dans le dépôt remi-test et les paquets de base dans le dépôt remi-test pour Fedora 30-31 ou remi-php73-test pour Enterprise Linux.

emblem-notice-24.pngPHP version 7.2 est désormais en mode maintenance de sécurité, il n'y aura donc plus de Release Candidate.

emblem-notice-24.pngInstallation : voir la Configuration du dépôt et choisir la version.

Installation en parallèle, en Software Collections de PHP 7.4 :

yum --enablerepo=remi-test install php74

Installation en parallèle, en Software Collections de PHP 7.3 :

yum --enablerepo=remi-test install php73

Mise à jour, de PHP 7.4 :

yum --enablerepo=remi-php73,remi-php74-test update php\*

ou, en utilisant le module (Fedora et RHEL 8) :

dnf module reset php
dnf module enable php:remi-7.4
dnf --enablerepo=remi-modular-test update php\*

Mise à jour, de PHP 7.3:

yum --enablerepo=remi-php73,remi-php73-test update php\*

ou, en utilisant le module (Fedora et RHEL 8) :

dnf module reset php
dnf module enable php:remi-7.3
dnf --enablerepo=remi-modular-test update php\*

A noter : la version 7.4.10RC1 est dans Fedora rawhide pour la QA

emblem-notice-24.pngles paquets utilisent désormais libicu65 (version 65.1)

emblem-notice-24.pngLes paquets pour EL-8 on été construit à partir de RHEL-8.2

emblem-notice-24.pngLes paquets pour EL-7 on été construit à partir de RHEL-7.8

emblem-notice-24.pngLa version RC est généralement identique à la version finale (aucun changement accepté, à l'exception de correctifs de sécurité)

emblem-notice-24.pngLa version 8.0.0beta2 est également disponible en Software Collections

 

Software Collections (php73, php74)

Paquets standards (php)

PHP version 7.2.33, 7.3.21 et 7.4.9

Remi Collet

Les RPM de PHP version 7.4.9 sont disponibles dans le dépôt remi pour Fedora 32 et dans le dépôt remi-php74 pour Fedora 30-31 et Enterprise Linux 7 (RHEL, CentOS).

Les RPM de PHP version 7.3.21 sont disponibles dans le dépôt remi pour Fedora 30-31 et dans le dépôt remi-php73 pour Enterprise Linux 6 (RHEL, CentOS).

Les RPM de PHP version 7.2.33 sont disponibles dans le dépôt remi-php72 pour Enterprise Linux 6 (RHEL, CentOS).

emblem-notice-24.pngPas de correctifs de sécurité ce mois ci.

emblem-important-2-24.png PHP version 7.1 a atteint sa fin de vie et n'est plus maintenu par le projet PHP.

Ces versions sont aussi disponibles en Software Collections dans le dépôt remi-safe et en module pour Fedora 30-32 et EL-8.

security-medium-2-24.pngCes versions corrigent quelques failles de sécurité, la mise à jour est donc vivement recommandée.

Annonces des versions :

emblem-notice-24.pngInstallation : voir l'assistant de configuration et choisir la version et le mode d'installation.

Remplacement du PHP par défaut du système par la version 7.4 (le plus simple) :

yum-config-manager --enable remi-php74
yum update

ou, en utilisant le module (Fedora et EL-8) :

dnf module enable php:remi-7.4
dnf update php\*

Installation en parallèle, en Software Collection de PHP 7.4

yum install php74

Remplacement du PHP par défaut du système par la version 7.3 (le plus simple) :

yum-config-manager --enable remi-php73
yum update

ou, en utilisant le module (Fedora et EL-8) :

dnf module enable php:remi-7.3
dnf update php\*

Installation en parallèle, en Software Collection de PHP 7.3

yum install php73

Et bientôt dans les mises à jour officielles:

emblem-important-2-24.pngÀ noter :

  • les paquets EL-8 sont construits avec RHEL-8.2
  • les paquets EL-7 sont construits avec RHEL-7.8
  • les paquets EL-6 sont construits avec RHEL-6.10
  • les paquets EL-7 utilisent désormais libicu65 (version 65.1)
  • les paquets EL utilisent désormais oniguruma5php (version 6.9.5, au lieu de la version ancienne du système)
  • l'extension oci8 utilise désormais le client Oracle version 19.6 (sauf EL-6)
  • beaucoup de nouvelles extensions sont aussi disponible, voir PECL extension RPM status page

emblem-notice-24.pngInformations, lire :

Paquets de base (php)

Software Collections (php72 / php73 / php74)

PHP version 7.3.21RC1 et 7.4.9RC1

Remi Collet

Les versions Release Candidate sont disponibles dans le dépôt de test pour Fedora et Enterprise Linux (RHEL / CentOS) afin de permettre au plus grand nombre de les tester. Elles sont  fournit en Software Collections, pour une installation en parallèle, solution idéale pour ce type de tests.et également en paquets de base.

Les RPM de PHP version 7.4.9RC1 sont disponibles en SCL dans le dépôt remi-test et les paquets de base dans le dépôt remi-test pour Fedora 32 ou remi-php74-test pour Fedora 30-31 et Enterprise Linux 7-8

Les RPM de PHP version 7.3.21RC1 sont disponibles en SCL dans le dépôt remi-test et les paquets de base dans le dépôt remi-test pour Fedora 30-31 ou remi-php73-test pour Enterprise Linux.

emblem-notice-24.pngPHP version 7.2 est désormais en mode maintenance de sécurité, il n'y aura donc plus de Release Candidate.

emblem-notice-24.pngInstallation : voir la Configuration du dépôt et choisir la version.

Installation en parallèle, en Software Collections de PHP 7.4 :

yum --enablerepo=remi-test install php74

Installation en parallèle, en Software Collections de PHP 7.3 :

yum --enablerepo=remi-test install php73

Mise à jour, de PHP 7.4 :

yum --enablerepo=remi-php73,remi-php74-test update php\*

ou, en utilisant le module (Fedora et RHEL 8) :

dnf module reset php
dnf module enable php:remi-7.4
dnf --enablerepo=remi-modular-test update php\*

Mise à jour, de PHP 7.3:

yum --enablerepo=remi-php73,remi-php73-test update php\*

ou, en utilisant le module (Fedora et RHEL 8) :

dnf module reset php
dnf module enable php:remi-7.3
dnf --enablerepo=remi-modular-test update php\*

A noter : la version 7.4.9RC1 est dans Fedora rawhide pour la QA

emblem-notice-24.pngles paquets utilisent désormais libicu65 (version 65.1)

emblem-notice-24.pngLes paquets pour EL-8 on été construit à partir de RHEL-8.2

emblem-notice-24.pngLes paquets pour EL-7 on été construit à partir de RHEL-7.8

emblem-notice-24.pngLa version RC est généralement identique à la version finale (aucun changement accepté, à l'exception de correctifs de sécurité)

emblem-notice-24.pngLa version 8.0.0alpha3 est également disponible en Software Collections

 

Software Collections (php73, php74)

Paquets standards (php)

PHP version 7.2.32, 7.3.20 et 7.4.8

Remi Collet

Les RPM de PHP version 7.4.8 sont disponibles dans le dépôt remi pour Fedora 32 et dans le dépôt remi-php74 pour Fedora 30-31 et Enterprise Linux 7 (RHEL, CentOS).

Les RPM de PHP version 7.3.20 sont disponibles dans le dépôt remi pour Fedora 30-31 et dans le dépôt remi-php73 pour Enterprise Linux 6 (RHEL, CentOS).

Les RPM de PHP version 7.2.32 sont disponibles dans le dépôt remi-php72 pour Enterprise Linux 6 (RHEL, CentOS).

emblem-notice-24.pngPas de correctifs de sécurité ce mois ci.

emblem-important-2-24.png PHP version 7.1 a atteint sa fin de vie et n'est plus maintenu par le projet PHP.

Ces versions sont aussi disponibles en Software Collections dans le dépôt remi-safe et en module pour Fedora 30-32 et EL-8.

Annonces des versions :

emblem-notice-24.pngInstallation : voir l'assistant de configuration et choisir la version et le mode d'installation.

Remplacement du PHP par défaut du système par la version 7.4 (le plus simple) :

yum-config-manager --enable remi-php74
yum update

ou, en utilisant le module (Fedora et EL-8) :

dnf module enable php:remi-7.4
dnf update php\*

Installation en parallèle, en Software Collection de PHP 7.4

yum install php74

Remplacement du PHP par défaut du système par la version 7.3 (le plus simple) :

yum-config-manager --enable remi-php73
yum update

ou, en utilisant le module (Fedora et EL-8) :

dnf module enable php:remi-7.3
dnf update php\*

Installation en parallèle, en Software Collection de PHP 7.3

yum install php73

Et bientôt dans les mises à jour officielles:

emblem-important-2-24.pngÀ noter :

  • les paquets EL-8 sont construits avec RHEL-8.2
  • les paquets EL-7 sont construits avec RHEL-7.8
  • les paquets EL-6 sont construits avec RHEL-6.10
  • les paquets EL-7 utilisent désormais libicu62 (version 62.1)
  • les paquets EL utilisent désormais oniguruma5php (version 6.9.5, au lieu de la version ancienne du système)
  • l'extension oci8 utilise désormais le client Oracle version 19.6 (sauf EL-6)
  • beaucoup de nouvelles extensions sont aussi disponible, voir PECL extension RPM status page

emblem-notice-24.pngInformations, lire :

Paquets de base (php)

Software Collections (php72 / php73 / php74)

PHP version 7.3.20RC1 et 7.4.8RC1

Remi Collet

Les versions Release Candidate sont disponibles dans le dépôt de test pour Fedora et Enterprise Linux (RHEL / CentOS) afin de permettre au plus grand nombre de les tester. Elles sont  fournit en Software Collections, pour une installation en parallèle, solution idéale pour ce type de tests.et également en paquets de base.

Les RPM de PHP version 7.4.8RC1 sont disponibles en SCL dans le dépôt remi-test et les paquets de base dans le dépôt remi-test pour Fedora 32 ou remi-php74-test pour Fedora 30-31 et Enterprise Linux 7-8

Les RPM de PHP version 7.3.20RC1 sont disponibles en SCL dans le dépôt remi-test et les paquets de base dans le dépôt remi-test pour Fedora 30-31 ou remi-php73-test pour Enterprise Linux.

emblem-notice-24.pngPHP version 7.2 est désormais en mode maintenance de sécurité, il n'y aura donc plus de Release Candidate.

emblem-notice-24.pngInstallation : voir la Configuration du dépôt et choisir la version.

Installation en parallèle, en Software Collections de PHP 7.4 :

yum --enablerepo=remi-test install php74

Installation en parallèle, en Software Collections de PHP 7.3 :

yum --enablerepo=remi-test install php73

Mise à jour, de PHP 7.4 :

yum --enablerepo=remi-php73,remi-php74-test update php\*

ou, en utilisant le module (Fedora et RHEL 8) :

dnf module reset php
dnf module enable php:remi-7.4
dnf --enablerepo=remi-modular-test update php\*

Mise à jour, de PHP 7.3:

yum --enablerepo=remi-php73,remi-php73-test update php\*

ou, en utilisant le module (Fedora et RHEL 8) :

dnf module reset php
dnf module enable php:remi-7.3
dnf --enablerepo=remi-modular-test update php\*

A noter : la version 7.4.8RC1 est dans Fedora rawhide pour la QA

emblem-notice-24.pngLes paquets pour EL-8 on été construit à partir de RHEL-8.2

emblem-notice-24.pngLes paquets pour EL-7 on été construit à partir de RHEL-7.8

emblem-notice-24.pngLa version RC est généralement identique à la version finale (aucun changement accepté, à l'exception de correctifs de sécurité)

 

Software Collections (php73, php74)

Paquets standards (php)

PHP version 7.3.19 et 7.4.7

Remi Collet

Les RPM de PHP version 7.4.7 sont disponibles dans le dépôt remi pour Fedora 32 et dans le dépôt remi-php74 pour Fedora 30-31 et Enterprise Linux 7 (RHEL, CentOS).

Les RPM de PHP version 7.3.19 sont disponibles dans le dépôt remi pour Fedora 30-31 et dans le dépôt remi-php73 pour Enterprise Linux 6 (RHEL, CentOS).

emblem-notice-24.pngPas de correctifs de sécurité ce mois ci, donc pas de mise à jour de la version 7.2.31.

emblem-important-2-24.png PHP version 7.1 a atteint sa fin de vie et n'est plus maintenu par le projet PHP.

Ces versions sont aussi disponibles en Software Collections dans le dépôt remi-safe et en module pour Fedora 30-32 et EL-8.

Annonces des versions :

emblem-notice-24.pngInstallation : voir l'assistant de configuration et choisir la version et le mode d'installation.

Remplacement du PHP par défaut du système par la version 7.4 (le plus simple) :

yum-config-manager --enable remi-php74
yum update

ou, en utilisant le module (Fedora et EL-8) :

dnf module enable php:remi-7.4
dnf update php\*

Installation en parallèle, en Software Collection de PHP 7.4

yum install php74

Remplacement du PHP par défaut du système par la version 7.3 (le plus simple) :

yum-config-manager --enable remi-php73
yum update

ou, en utilisant le module (Fedora et EL-8) :

dnf module enable php:remi-7.3
dnf update php\*

Installation en parallèle, en Software Collection de PHP 7.3

yum install php73

Et bientôt dans les mises à jour officielles:

emblem-important-2-24.pngÀ noter :

  • les paquets EL-8 sont construits avec RHEL-8.1
  • les paquets EL-7 sont construits avec RHEL-7.8
  • les paquets EL-6 sont construits avec RHEL-6.10
  • les paquets EL-7 utilisent désormais libicu62 (version 62.1)
  • les paquets EL utilisent désormais oniguruma5php (version 6.9.5, au lieu de la version ancienne du système)
  • l'extension oci8 utilise désormais le client Oracle version 19.6 (sauf EL-6)
  • beaucoup de nouvelles extensions sont aussi disponible, voir PECL extension RPM status page

emblem-notice-24.pngInformations, lire :

Paquets de base (php)

Software Collections (php72 / php73 / php74)

PHP version 7.3.19RC1 et 7.4.7RC1

Remi Collet

Les versions Release Candidate sont disponibles dans le dépôt de test pour Fedora et Enterprise Linux (RHEL / CentOS) afin de permettre au plus grand nombre de les tester. Elles sont  fournit en Software Collections, pour une installation en parallèle, solution idéale pour ce type de tests.et également en paquets de base.

Les RPM de PHP version 7.4.7RC1 sont disponibles en SCL dans le dépôt remi-test et les paquets de base dans le dépôt remi-test pour Fedora 32 ou remi-php74-test pour Fedora 30-31 et Enterprise Linux 7-8

Les RPM de PHP version 7.3.19RC1 sont disponibles en SCL dans le dépôt remi-test et les paquets de base dans le dépôt remi-test pour Fedora 30-31 ou remi-php73-test pour Enterprise Linux.

emblem-notice-24.pngPHP version 7.2 est désormais en mode maintenance de sécurité, il n'y aura donc plus de Release Candidate.

emblem-notice-24.pngInstallation : voir la Configuration du dépôt et choisir la version.

Installation en parallèle, en Software Collections de PHP 7.4 :

yum --enablerepo=remi-test install php74

Installation en parallèle, en Software Collections de PHP 7.3 :

yum --enablerepo=remi-test install php73

Mise à jour, de PHP 7.4 :

yum --enablerepo=remi-php73,remi-php74-test update php\*

ou, en utilisant le module (Fedora et RHEL 8) :

dnf module reset php
dnf module enable php:remi-7.4
dnf --enablerepo=remi-modular-test update php\*

Mise à jour, de PHP 7.3:

yum --enablerepo=remi-php73,remi-php73-test update php\*

ou, en utilisant le module (Fedora et RHEL 8) :

dnf module reset php
dnf module enable php:remi-7.3
dnf --enablerepo=remi-modular-test update php\*

A noter : la version 7.4.7RC1 est dans Fedora rawhide pour la QA

emblem-notice-24.pngLes paquets pour EL-8 on été construit à partir de RHEL-8.1

emblem-notice-24.pngLes paquets pour EL-7 on été construit à partir de RHEL-7.8

emblem-notice-24.pngLa version RC est généralement identique à la version finale (aucun changement accepté, à l'exception de correctifs de sécurité)

 

Software Collections (php73, php74)

Paquets standards (php)

PHP version 7.2.31, 7.3.18 et 7.4.6

Remi Collet

Les RPM de PHP version 7.4.6 sont disponibles dans le dépôt remi pour Fedora 32 et dans le dépôt remi-php74 pour Fedora 30-31 et Enterprise Linux 7 (RHEL, CentOS).

Les RPM de PHP version 7.3.18 sont disponibles dans le dépôt remi pour Fedora 30-31 et dans le dépôt remi-php73 pour Enterprise Linux 6 (RHEL, CentOS).

Les RPM de PHP version 7.2.31 sont disponibles dans le dépôt remi-php72 pour Enterprise Linux 6 (RHEL, CentOS).

emblem-important-2-24.png PHP version 7.1 a atteint sa fin de vie et n'est plus maintenu par le projet PHP.

Ces versions sont aussi disponibles en Software Collections dans le dépôt remi-safe et en module pour Fedora 30-32 et EL-8.

security-medium-2-24.pngCes versions corrigent quelques failles de sécurité, la mise à jour est donc vivement recommandée.

Annonces des versions :

emblem-notice-24.pngInstallation : voir l'assistant de configuration et choisir la version et le mode d'installation.

Remplacement du PHP par défaut du système par la version 7.4 (le plus simple) :

yum-config-manager --enable remi-php74
yum update

ou, en utilisant le module (Fedora et EL-8) :

dnf module enable php:remi-7.4
dnf update php\*

Installation en parallèle, en Software Collection de PHP 7.4

yum install php74

Remplacement du PHP par défaut du système par la version 7.3 (le plus simple) :

yum-config-manager --enable remi-php73
yum update

ou, en utilisant le module (Fedora et EL-8) :

dnf module enable php:remi-7.3
dnf update php\*

Installation en parallèle, en Software Collection de PHP 7.3

yum install php73

Et bientôt dans les mises à jour officielles:

emblem-important-2-24.pngÀ noter :

  • les paquets EL-8 sont construits avec RHEL-8.1
  • les paquets EL-7 sont construits avec RHEL-7.8
  • les paquets EL-6 sont construits avec RHEL-6.10
  • les paquets EL-7 utilisent désormais libicu62 (version 62.1)
  • les paquets EL utilisent désormais oniguruma5 (version 6.9.4, au lieu de la version embarquée)
  • l'extension oci8 utilise désormais le client Oracle version 19.6 (sauf EL-6)
  • beaucoup de nouvelles extensions sont aussi disponible, voir PECL extension RPM status page

emblem-notice-24.pngInformations, lire :

Paquets de base (php)

Software Collections (php72 / php73 / php74)

PHP version 7.3.18RC1 et 7.4.6RC1

Remi Collet

Les versions Release Candidate sont disponibles dans le dépôt de test pour Fedora et Enterprise Linux (RHEL / CentOS) afin de permettre au plus grand nombre de les tester. Elles sont  fournit en Software Collections, pour une installation en parallèle, solution idéale pour ce type de tests.et également en paquets de base.

Les RPM de PHP version 7.4.6RC1 sont disponibles en SCL dans le dépôt remi-test et les paquets de base dans le dépôt remi-test pour Fedora 32 ou remi-php74-test pour Fedora 30-31 et Enterprise Linux 7-8

Les RPM de PHP version 7.3.18RC1 sont disponibles en SCL dans le dépôt remi-test et les paquets de base dans le dépôt remi-test pour Fedora 30-31 ou remi-php73-test pour Enterprise Linux.

emblem-notice-24.pngPHP version 7.2 est désormais en mode maintenance de sécurité, il n'y aura donc plus de Release Candidate.

emblem-notice-24.pngInstallation : voir la Configuration du dépôt et choisir la version.

Installation en parallèle, en Software Collections de PHP 7.4 :

yum --enablerepo=remi-test install php74

Installation en parallèle, en Software Collections de PHP 7.3 :

yum --enablerepo=remi-test install php73

Mise à jour, de PHP 7.4 :

yum --enablerepo=remi-php73,remi-php74-test update php\*

ou, en utilisant le module (Fedora et RHEL 8) :

dnf module reset php
dnf module enable php:remi-7.4
dnf --enablerepo=remi-modular-test update php\*

Mise à jour, de PHP 7.3:

yum --enablerepo=remi-php73,remi-php73-test update php\*

ou, en utilisant le module (Fedora et RHEL 8) :

dnf module reset php
dnf module enable php:remi-7.3
dnf --enablerepo=remi-modular-test update php\*

A noter : la version 7.4.6RC1 est dans Fedora rawhide pour la QA

emblem-notice-24.pngLes paquets pour EL-8 on été construit à partir de RHEL-8.1

emblem-notice-24.pngLes paquets pour EL-7 on été construit à partir de RHEL-7.8

emblem-notice-24.pngLa version RC est généralement identique à la version finale (aucun changement accepté, à l'exception de correctifs de sécurité)

 

Software Collections (php73, php74)

Paquets standards (php)

PHP version 7.2.30, 7.3.17 et 7.4.5

Remi Collet

Les RPM de PHP version 7.4.5 sont disponibles dans le dépôt remi pour Fedora 32 et dans le dépôt remi-php74 pour Fedora 30-31 et Enterprise Linux 7 (RHEL, CentOS).

Les RPM de PHP version 7.3.17 sont disponibles dans le dépôt remi pour Fedora 30-31 et dans le dépôt remi-php73 pour Enterprise Linux 6 (RHEL, CentOS).

Les RPM de PHP version 7.2.30 sont disponibles dans le dépôt remi-php72 pour Enterprise Linux 6 (RHEL, CentOS).

emblem-important-2-24.png PHP version 7.1 a atteint sa fin de vie et n'est plus maintenu par le projet PHP.

Ces versions sont aussi disponibles en Software Collections dans le dépôt remi-safe et en module pour Fedora 30-32 et EL-8.

security-medium-2-24.pngCes versions corrigent quelques failles de sécurité, la mise à jour est donc vivement recommandée.

Annonces des versions :

emblem-notice-24.pngInstallation : voir l'assistant de configuration et choisir la version et le mode d'installation.

Remplacement du PHP par défaut du système par la version 7.4 (le plus simple) :

yum-config-manager --enable remi-php74
yum update

ou, en utilisant le module (Fedora et EL-8) :

dnf module enable php:remi-7.4
dnf update php\*

Installation en parallèle, en Software Collection de PHP 7.4

yum install php74

Remplacement du PHP par défaut du système par la version 7.3 (le plus simple) :

yum-config-manager --enable remi-php73
yum update

ou, en utilisant le module (Fedora et EL-8) :

dnf module enable php:remi-7.3
dnf update php\*

Installation en parallèle, en Software Collection de PHP 7.3

yum install php73

Et bientôt dans les mises à jour officielles:

emblem-important-2-24.pngÀ noter :

  • les paquets EL-8 sont construits avec RHEL-8.1
  • les paquets EL-7 sont construits avec RHEL-7.7
  • les paquets EL-6 sont construits avec RHEL-6.10
  • les paquets EL-7 utilisent désormais libicu62 (version 62.1)
  • les paquets EL utilisent désormais oniguruma5 (version 6.9.4, au lieu de la version embarquée)
  • l'extension oci8 utilise désormais le client Oracle version 19.6 (sauf EL-6)
  • beaucoup de nouvelles extensions sont aussi disponible, voir PECL extension RPM status page

emblem-notice-24.pngInformations, lire :

Paquets de base (php)

Software Collections (php72 / php73 / php74)

PHP 8.0 en Software Collection

Remi Collet

La version 8.0.0-alpha1 sera prochainement publiée. C'est actuellement la phase de développement, mais la phase de stabilisation va bientôt commencer pour les développeurs, et celle de test pour les utilisateurs.

Les RPM de cette prochaine version de PHP 8.0, sont disponibles dans le dépôt remi pour Fedora 31, 32 et Enterprise Linux 7, 8 (RHEL, CentOS, ...) dans une nouvelle Software Collection (php80) permettant son installation en parallèle de la version système.

Comme je crois fortement au potentiel des SCL pour fournir un moyen simple d'installer plusieurs versions en parallèle, et qu'il me semble utile d'offrir cette possibilité pour PHP 8.0 afin de permettre aux développeurs de tester leur application, aux sysadmin de préparer une migration, ou simplement d'utiliser cette version pour une application spécifique, j'ai décidé de créer cette nouvelle SCL.

Je prévois aussi de proposer cette version pour Fedora 34 (F33 devrait être publiée quelques semaines avant PHP 8.0.0).

Installation :

yum install php80

emblem-important-2-24.pngA noter :

  • la SCL est totalement indépendante du système, et ne le modifie pas
  • cette SCL est dans le dépôt remi-safe (dans le dépôt remi pour Fedora)
  • l'installation est dans le dossier /opt/remi/php80, la configuration dans le dossier /etc/opt/remi/php80
  • le module pour Apache, php80-php, est disponible, mais évidement un seul mod_php peut être utiliser (il faudrait donc désactiver ou désinstaller tout autre module afin de l'utiliser, celui fournit par le paquet "php" reste prioritaire)
  • le service FPM (php80-php-fpm) est disponible, il écoute par défaut sur le port 9000, il faudrait donc adapter la configuration si vous souhaitez utiliser plusieurs services FPM en même temps.
  • la commande php80 permet d'accéder simplement à cette version, cependant l'utilisation de la commande scl reste la meilleure méthode (ou module)
  • Il s'agit pour l'instant de la version 8.0.0-dev, mais les versions alpha/beta/RC devrait être disponibles dans les prochaines semaines.
  • quelques extensions PECL sont déjà disponibles, voir la page status des extensions
  • seulement pour  x86_64, pas de plan pour les autres architectures.
  • le paquet php80-syspaths permet de l'utiliser comme version par défaut du système

emblem-notice-24.pngLire aussi les autres articles concernant les SCL, notamment la description de Ma station de travail PHP.

$ module load php80
$ php --version
PHP 8.0.0-dev (cli) (built: Apr  9 2020 16:31:18) ( NTS )
Copyright (c) The PHP Group
Zend Engine v4.0.0-dev, Copyright (c) Zend Technologies
    with Zend OPcache v8.0.0-dev, Copyright (c), by Zend Technologies

Comme d'habitude, vos retours sont les bienvenus, un forum dédié aux SCL est ouvert.

Software Collections (php80)

PHP version 7.3.17RC1 et 7.4.5RC1

Remi Collet

Les versions Release Candidate sont disponibles dans le dépôt de test pour Fedora et Enterprise Linux (RHEL / CentOS) afin de permettre au plus grand nombre de les tester. Elles sont  fournit en Software Collections, pour une installation en parallèle, solution idéale pour ce type de tests.et également en paquets de base.

Les RPM de PHP version 7.4.5RC1 sont disponibles en SCL dans le dépôt remi-test et les paquets de base dans le dépôt remi-test pour Fedora 32 ou remi-php74-test pour Fedora 30-31 et Enterprise Linux 7-8

Les RPM de PHP version 7.3.17RC1 sont disponibles en SCL dans le dépôt remi-test et les paquets de base dans le dépôt remi-test pour Fedora 30-31 ou remi-php73-test pour Enterprise Linux.

emblem-notice-24.pngPHP version 7.2 est désormais en mode maintenance de sécurité, il n'y aura donc plus de Release Candidate.

emblem-notice-24.pngInstallation : voir la Configuration du dépôt et choisir la version.

Installation en parallèle, en Software Collections de PHP 7.4 :

yum --enablerepo=remi-test install php74

Installation en parallèle, en Software Collections de PHP 7.3 :

yum --enablerepo=remi-test install php73

Mise à jour, de PHP 7.4 :

yum --enablerepo=remi-php73,remi-php74-test update php\*

ou, en utilisant le module (Fedora et RHEL 8) :

dnf module reset php
dnf module enable php:remi-7.4
dnf --enablerepo=remi-modular-test update php\*

Mise à jour, de PHP 7.3:

yum --enablerepo=remi-php73,remi-php73-test update php\*

ou, en utilisant le module (Fedora et RHEL 8) :

dnf module reset php
dnf module enable php:remi-7.3
dnf --enablerepo=remi-modular-test update php\*

A noter : la version 7.4.5RC1 est dans Fedora rawhide pour la QA

emblem-notice-24.pngLes paquets pour EL-8 on été construit à partir de RHEL-8.1

emblem-notice-24.pngLes paquets pour EL-7 on été construit à partir de RHEL-7.7

emblem-notice-24.pngLa version RC est généralement identique à la version finale (aucun changement accepté, à l'exception de correctifs de sécurité)

 

Software Collections (php73, php74)

Paquets standards (php)

PHP version 7.2.29, 7.3.16 et 7.4.4

Remi Collet

Les RPM de PHP version 7.4.4 sont disponibles dans le dépôt remi pour Fedora 32 et dans le dépôt remi-php74 pour Fedora 30-31 et Enterprise Linux 7 (RHEL, CentOS).

Les RPM de PHP version 7.3.16 sont disponibles dans le dépôt remi pour Fedora 30-31 et dans le dépôt remi-php73 pour Enterprise Linux 6 (RHEL, CentOS).

Les RPM de PHP version 7.2.29 sont disponibles dans le dépôt remi-php72 pour Enterprise Linux 6 (RHEL, CentOS).

emblem-important-2-24.png PHP version 7.1 a atteint sa fin de vie et n'est plus maintenu par le projet PHP.

Ces versions sont aussi disponibles en Software Collections dans le dépôt remi-safe et en module pour Fedora 30-32 et EL-8.

security-medium-2-24.pngCes versions corrigent quelques failles de sécurité, la mise à jour est donc vivement recommandée.

Annonces des versions :

emblem-notice-24.pngInstallation : voir l'assistant de configuration et choisir la version et le mode d'installation.

Remplacement du PHP par défaut du système par la version 7.4 (le plus simple) :

yum-config-manager --enable remi-php74
yum update

ou, en utilisant le module (Fedora et EL-8) :

dnf module enable php:remi-7.4
dnf update php\*

Installation en parallèle, en Software Collection de PHP 7.4

yum install php74

Remplacement du PHP par défaut du système par la version 7.3 (le plus simple) :

yum-config-manager --enable remi-php73
yum update

ou, en utilisant le module (Fedora et EL-8) :

dnf module enable php:remi-7.3
dnf update php\*

Installation en parallèle, en Software Collection de PHP 7.3

yum install php73

Et bientôt dans les mises à jour officielles:

emblem-important-2-24.pngÀ noter :

  • les paquets EL-8 sont construits avec RHEL-8.1
  • les paquets EL-7 sont construits avec RHEL-7.7
  • les paquets EL-6 sont construits avec RHEL-6.10
  • les paquets EL-7 utilisent désormais libicu62 (version 62.1)
  • les paquets EL utilisent désormais oniguruma5 (version 6.9.4, au lieu de la version embarquée)
  • l'extension oci8 utilise désormais le client Oracle version 19.6 (sauf EL-6)
  • beaucoup de nouvelles extensions sont aussi disponible, voir PECL extension RPM status page

emblem-notice-24.pngInformations, lire :

Paquets de base (php)

Software Collections (php72 / php73 / php74)

PHP version 7.3.16RC1 et 7.4.4RC1

Remi Collet

Les versions Release Candidate sont disponibles dans le dépôt de test pour Fedora et Enterprise Linux (RHEL / CentOS) afin de permettre au plus grand nombre de les tester. Elles sont  fournit en Software Collections, pour une installation en parallèle, solution idéale pour ce type de tests.et également en paquets de base.

Les RPM de PHP version 7.4.4RC1 sont disponibles en SCL dans le dépôt remi-test et les paquets de base dans le dépôt remi-test pour Fedora 32 ou remi-php74-test pour Fedora 30-31 et Enterprise Linux 7-8

Les RPM de PHP version 7.3.16RC1 sont disponibles en SCL dans le dépôt remi-test et les paquets de base dans le dépôt remi-test pour Fedora 30-31 ou remi-php73-test pour Enterprise Linux.

emblem-notice-24.pngPHP version 7.2 est désormais en mode maintenance de sécurité, il n'y aura donc plus de Release Candidate.

emblem-notice-24.pngInstallation : voir la Configuration du dépôt et choisir la version.

Installation en parallèle, en Software Collections de PHP 7.4 :

yum --enablerepo=remi-test install php74

Installation en parallèle, en Software Collections de PHP 7.3 :

yum --enablerepo=remi-test install php73

Mise à jour, de PHP 7.4 :

yum --enablerepo=remi-php73,remi-php74-test update php\*

ou, en utilisant le module (Fedora et RHEL 8) :

dnf module reset php
dnf module enable php:remi-7.4
dnf --enablerepo=remi-modular-test update php\*

Mise à jour, de PHP 7.3:

yum --enablerepo=remi-php73,remi-php73-test update php\*

ou, en utilisant le module (Fedora et RHEL 8) :

dnf module reset php
dnf module enable php:remi-7.3
dnf --enablerepo=remi-modular-test update php\*

A noter : la version 7.4.4RC1 est dans Fedora rawhide pour la QA

emblem-notice-24.pngLes paquets pour EL-8 on été construit à partir de RHEL-8.1

emblem-notice-24.pngLes paquets pour EL-7 on été construit à partir de RHEL-7.7

emblem-notice-24.pngLa version RC est généralement identique à la version finale (aucun changement accepté, à l'exception de correctifs de sécurité)

 

Software Collections (php73, php74)

Paquets standards (php)

PHP version 7.2.28, 7.3.15 et 7.4.3

Remi Collet

Les RPM de PHP version 7.4.3 sont disponibles dans le dépôt remi pour Fedora 32 et dans le dépôt remi-php74 pour Fedora ≥ 30 et Enterprise Linux 7 (RHEL, CentOS).

Les RPM de PHP version 7.3.15 sont disponibles dans le dépôt remi pour Fedora 30-31 et dans le dépôt remi-php73 pour Enterprise Linux 6 (RHEL, CentOS).

Les RPM de PHP version 7.2.28 sont disponibles dans le dépôt remi-php72 pour Enterprise Linux 6 (RHEL, CentOS).

emblem-important-2-24.png PHP version 7.1 a atteint sa fin de vie et n'est plus maintenu par le projet PHP.

Ces versions sont aussi disponibles en Software Collections dans le dépôt remi-safe et en module pour Fedora 30-32 et EL-8.

security-medium-2-24.pngCes versions corrigent quelques failles de sécurité, la mise à jour est donc vivement recommandée.

Annonces des versions :

emblem-notice-24.pngInstallation : voir l'assistant de configuration et choisir la version et le mode d'installation.

Remplacement du PHP par défaut du système par la version 7.4 (le plus simple) :

yum-config-manager --enable remi-php74
yum update

ou, en utilisant le module (Fedora et EL-8) :

dnf module enable php:remi-7.4
dnf update php\*

Installation en parallèle, en Software Collection de PHP 7.4

yum install php74

Remplacement du PHP par défaut du système par la version 7.3 (le plus simple) :

yum-config-manager --enable remi-php73
yum update

ou, en utilisant le module (Fedora et EL-8) :

dnf module enable php:remi-7.3
dnf update php\*

Installation en parallèle, en Software Collection de PHP 7.3

yum install php73

Et bientôt dans les mises à jour officielles:

emblem-important-2-24.pngÀ noter :

  • les paquets EL-8 sont construits avec RHEL-8.1
  • les paquets EL-7 sont construits avec RHEL-7.7
  • les paquets EL-6 sont construits avec RHEL-6.10
  • les paquets EL-7 utilisent désormais libicu62 (version 62.1)
  • les paquets EL utilisent désormais oniguruma5 (version 6.9.4, au lieu de la version embarquée)
  • l'extension oci8 utilise désormais le client Oracle version 19.5 (sauf EL-6)
  • beaucoup de nouvelles extensions sont aussi disponible, voir PECL extension RPM status page

emblem-notice-24.pngInformations, lire :

Paquets de base (php)

Software Collections (php72 / php73 / php74)

PHPUnit 9

Remi Collet

Les RPM de PHPUnit version 9 sont disponibles dans le dépôt remi pour Fedora ≥ 29 et pour Enterprise Linux (CentOS, RHEL...).

Documentation :

emblem-notice-24.pngCette nouvelle version nécessite PHP ≥ 7.3 et n'est pas rétro-compatible avec les versions précédentes, donc s'installe en parallèle des versions 5, 6, 7 et 8.

Installation, Fedora et:Enterprise Linux 8 :

dnf --enablerepo=remi install phpunit9

Installation, Enterprise Linux 6 et 7 :

yum --enablerepo=remi install phpunit9

Remarque: cet outil est une pièce essentielle de la QA PHP dans Fedora. Cette version devrait être rapidement disponible dans Fedora ≥ 31 (après la revue des 19 nouveaux paquets).

PHP version 7.3.15RC1 et 7.4.3RC1

Remi Collet

Les versions Release Candidate sont disponibles dans le dépôt de test pour Fedora et Enterprise Linux (RHEL / CentOS) afin de permettre au plus grand nombre de les tester. Elles sont  fournit en Software Collections, pour une installation en parallèle, solution idéale pour ce type de tests.et également en paquets de base.

Les RPM de PHP version 7.4.3RC1 sont disponibles en SCL dans le dépôt remi-test et les paquets de base dans le dépôt remi-php74-test pour Fedora 29-30 et Enterprise Linux 7-8

Les RPM de PHP version 7.3.14RC1 sont disponibles en SCL dans le dépôt remi-test et les paquets de base dans le dépôt remi-test pour Fedora 30-31 ou remi-php73-test pour Fedora 29 et Enterprise Linux.

emblem-notice-24.pngPHP version 7.2 est désormais en mode maintenance de sécurité, il n'y aura donc plus de Release Candidate.

emblem-notice-24.pngInstallation : voir la Configuration du dépôt et choisir la version.

Installation en parallèle, en Software Collections de PHP 7.4 :

yum --enablerepo=remi-test install php74

Installation en parallèle, en Software Collections de PHP 7.3 :

yum --enablerepo=remi-test install php73

Mise à jour, de PHP 7.4 :

yum --enablerepo=remi-php73,remi-php74-test update php\*

ou, en utilisant le module (Fedora et RHEL 8) :

dnf module reset php
dnf module enable php:remi-7.4
dnf --enablerepo=remi-modular-test update php\*

Mise à jour, de PHP 7.3:

yum --enablerepo=remi-php73,remi-php73-test update php\*

ou, en utilisant le module (Fedora et RHEL 8) :

dnf module reset php
dnf module enable php:remi-7.3
dnf --enablerepo=remi-modular-test update php\*

A noter : la version 7.4.3RC1 est dans Fedora rawhide pour la QA

emblem-notice-24.pngLes paquets pour EL-8 on été construit à partir de RHEL-8.1

emblem-notice-24.pngLes paquets pour EL-7 on été construit à partir de RHEL-7.7

emblem-notice-24.pngLa version RC est généralement identique à la version finale (aucun changement accepté, à l'exception de correctifs de sécurité)

 

Software Collections (php73, php74)

Paquets standards (php)